Gas gauge and paint matching

thilt

New Member
Jun 5, 2017
11
0
1
60
#1
Hi everyone,
Great site.
So two issues...one fairly minor and one not.
First the minor one. My 03 is showing wear and tear. I want to keep it a while so I decided to fix some of the cosmetic blemishes myself. I filled the dings and scrapes with body filler and got some of that dupli-color stuff and tried to match the silver trim (white body/silver bumpers and wheel flares)...big mistake. I thought the color was going to be a lot closer than it was. I looks horrible and now I am thinking of taking it to a body shop. Before I do though, does anyone know where I can get the 03 silver trim paint? The color code on the door says 056/FB41, Natural white body and FB41??, I assumed to be the trim color. But I can't find that trim color anywhere. Other than a body shop, any ideas?
Now the major issue. My fuel sending unit just started acting up. Even though the tank if full, the gauge is reading sporadically anywhere in between 3/4 and 1/4. I'm assuming it is the sending unit. The Distance Tank Empty (DTE) reading is also whacked out. It is dropping super fast while I drive. Hell, it drops while I sit in the driveway with the engine running. Has anyone had this issue? I Googled it and see that some have had the issue (no one mentions the DTE problem) but cant find any solutions other than taking to the shop. I'd like to fix it myself if I can.
Any suggestions are welcome. Thanks.
Tim
 

thilt

New Member
Jun 5, 2017
11
0
1
60
#2
Update: My wife, who is an internet ninja, found my paint color. There is a company that sells the color I need in spray cans. Hopefully it matches.
The fuel sending unit issue may be helped by a couple of bottles of fuel system cleaner recommended in another forum.
I'll keep you posted.

Update: The fuel system cleaner seems to have worked great. My "broken" fuel gauge works perfect again. I never believed in the stuff till now. The engine runs noticeably better and it improved my gas mileage slightly (1 mile per gallon). I will throw a bottle in at each oil change.

As far as the paint, it was close, but did not match. It was a Scratchwizard product. I called them an told them that it was close but not perfect. I was not requesting a refund but they did anyway. They refunded me the total cost.
 
Last edited:
Jul 18, 2018
2
0
1
33
#3
if its not to much to ask what kind of cleaner did you use and how much of it. iv had mine swaped out from and older car but it didnt fix my sending unit i know alot of ppl have said just to get a new unit and get it overwith but as you know that can be very costy?
 
Jul 18, 2018
2
0
1
33
#4
Update: My wife, who is an internet ninja, found my paint color. There is a company that sells the color I need in spray cans. Hopefully it matches.
The fuel sending unit issue may be helped by a couple of bottles of fuel system cleaner recommended in another forum.
I'll keep you posted.

Update: The fuel system cleaner seems to have worked great. My "broken" fuel gauge works perfect again. I never believed in the stuff till now. The engine runs noticeably better and it improved my gas mileage slightly (1 mile per gallon). I will throw a bottle in at each oil change.

As far as the paint, it was close, but did not match. It was a Scratchwizard product. I called them an told them that it was close but not perfect. I was not requesting a refund but they did anyway. They refunded me the total cost.

if its not to much to ask what kind of cleaner did you use and how much of it. iv had mine swaped out from and older car but it didnt fix my sending unit i know alot of ppl have said just to get a new unit and get it overwith but as you know that can be very costy?
 

thilt

New Member
Jun 5, 2017
11
0
1
60
#5
I used Chevron Techron fuel system cleaner. Two 20 oz. bottles for two tanks full (one bottle per fill-up). It works good. Made quite a difference.
 
Dec 3, 2017
32
11
8
47
#6
The fuel gauge in my 04 does not read accurately. It will rise and fall without reason. I picked up parts to replace the fuel pump, filter, and sending unit. I'm at 170,000 miles.